Tags

, ,

image

Loopback Interface:
R1: 10.10.10.1/32
R2: 10.10.10.2/32
R3: 10.10.10.3/32
R4: 10.10.10.4/32
R5: 10.10.10.5/32

Connectivity between Provider Routers:
IP block used to connect Provider routers is 192.168. In additional there is additional loopback1 interface in R1(172.16.1.0/24) & R4(172.16.4.0/24).

OSPF as IGP used in provider network.

Provider has two customer. Customer1 Site1 will communicate with Customer1 Site2. For this Customer1 will connect with Provider via static route. Customer2 Site1 will communicate with Customer2 Site2. For this Customer2 will connect with Provider via OSPF.

TASK:
1. Configure interface accordingly.
2. Enable OSPF as IGP in Provider Core.
3. Enable MPLS in Provider Core.
4. Ensure that R1 loopback1 is reachable from R4 loopback1
5. Check the MPLS lable and tags.

Bellow is the standard templates used for all the routers:

hostname ROUTERNAME
ip cef
no ip domain-lookup
no ip http server
no ip http secure-server
no ip finger
no service pad
no service udp-small-server
no service tcp-small-server
no ip bootp server
no ip source-route
logging source-interface loopback 0
logging buffered 16384
service timestamps debug datetime msec
service timestamps log datetime msec
clock timezone UTC 06
ip routing
ip subnet-zero
ip classless
!
line console 0
logging synchronous
transport preferred none
exec-timeout 0 0

PHASE 1:

In PHASE 1 we enable MPLS in provider routers.

1. Enable CEF globally

R1(config)#ip cef

2. Activate LDP

R1(config)#mpls label protocol ldp

3. Enable MPLS per interface

R1(config-if)#mpls ip

[Please do the same for the rest of the routers R2, R3, R4 & R5]

Bellow are the routers configurations:

R1:

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
router ospf 100
network 10.10.10.1 0.0.0.0 area 0
network 172.16.1.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.3 area 0

R2:

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet1/0
ip address 192.168.23.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet2/0
ip address 192.168.25.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
network 192.168.25.0 0.0.0.3 area 0

R3:

interface Loopback0
ip address 10.10.10.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.23.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet1/0
ip address 192.168.34.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet2/0
ip address 192.168.35.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.23.0 0.0.0.3 area 0
network 192.168.34.0 0.0.0.3 area 0
network 192.168.35.0 0.0.0.3 area 0

R4:

interface Loopback0
ip address 10.10.10.4 255.255.255.255
!
interface Loopback1
ip address 172.16.4.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
network 10.10.10.4 0.0.0.0 area 0
network 172.16.4.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.3 area 0

R5:

interface Loopback0
ip address 10.10.10.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.35.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet1/0
ip address 192.168.25.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
network 10.10.10.5 0.0.0.0 area 0
network 192.168.25.0 0.0.0.3 area 0
network 192.168.35.0 0.0.0.3 area 0

Few output:

R1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 192.168.23.0/30 0 Fa0/0 192.168.12.2
17 17 192.168.35.0/30 0 Fa0/0 192.168.12.2
18 16 192.168.34.0/30 0 Fa0/0 192.168.12.2
19 Pop tag 192.168.25.0/30 0 Fa0/0 192.168.12.2
20 Pop tag 10.10.10.2/32 0 Fa0/0 192.168.12.2
21 19 10.10.10.3/32 0 Fa0/0 192.168.12.2
22 20 10.10.10.5/32 0 Fa0/0 192.168.12.2
23 22 10.10.10.4/32 0 Fa0/0 192.168.12.2
24 23 172.16.4.1/32 0 Fa0/0 192.168.12.2

R1#traceroute
Protocol [ip]:
Target IP address: 172.16.4.1
Source address: 172.16.1.1
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 172.16.4.1

1 192.168.12.2 [MPLS: Label 23 Exp 0] 140 msec 136 msec 252 msec
2 192.168.23.2 [MPLS: Label 23 Exp 0] 100 msec 156 msec 16 msec
3 192.168.34.2 316 msec * 8 msec

In next blog we will configure MPLS L3 VPN for Customer 1 & Customer 2.